1. Welcome. We have only just upgraded so there may be a few little niggles and issues! Please let us know when you find them! And enjoy the super shiny new forums

bad luck or just bad luck??? egine managment light on!!!

Discussion in 'Tech Questions & How To Guides' started by 1.8GSturbo, Apr 22, 2010.

Advert:
  1. 1.8GSturbo

    1.8GSturbo New Member

    Joined:
    Mar 3, 2010
    Messages:
    38
    Likes Received:
    0
    just got my baby back the road was going down the m40 under triple figers and the engine management light came on! then off just under 4k rpm then on......

    i pulled into wheatly services and turned the car off and it wouldnt start for a couple of minutes then the light went off brooom....

    went to my mates house 5 miles away parked up for 10 min wouldnt start again the light was on!!!!!!!!

    hour later its starts....

    wen the lights on it will run for about 5 seconds really lumpy like on 2 cylinders and just cut out!!!

    wen its off its fine purrrrs like my cat

    i noticed it sumtimes comes on wen i give it beans its a 4speed triptronic and i think its restricted???... and maybe thats causing it to cut out???

    i have a airfilter fitted could that be it?
    remap needed??
    had a new key cut today???
    grrr!!!!
    wen i brought it the guy said it does it sometimes but i had it 3 months and except the disel thing it was fine!!

    is there a fuel cut off divice on these??
    does the ecu save the last fault so i can get it checked without it deleting its self....?????
    1 thing after another!!!!!
     
    #1
  2. ElDopesta

    ElDopesta New Member

    Joined:
    Jun 2, 2009
    Messages:
    5,703
    Likes Received:
    144
    Check your dip stick and then check the plugs.

    Did you do an oil change???

    Put some Forte fuel additive in too buddy but don't buy a cheapy one.

    Keep me posted on this one.

    I will think about it over night.

    Had too many late ones and not thinking too tight.

    El
     
    #2
  3. 1.8GSturbo

    1.8GSturbo New Member

    Joined:
    Mar 3, 2010
    Messages:
    38
    Likes Received:
    0
    oil is fine... plugs a litlle bit cokey. been doing that since the disel i think.
    gonna get the injectors cleaned next week but they wouldnt stop it from running now and then would they...
    coil packs?
    i getting it pluged in tommorrow hopefully
     
    #3
  4. ElDopesta

    ElDopesta New Member

    Joined:
    Jun 2, 2009
    Messages:
    5,703
    Likes Received:
    144
    Best thing for it. You will be better of with the Forte then taking the injectors off. It cost around £14 but it is worth every penny. You will notice a better acceleration and smoother idle. It will clean out your injectors and the electrodes on your plugs as well as the residue in the tank and any deposits that have built up in the engine such as carbon which I am sure is in you injectors right now and in the valves etc.

    Your engine def has contaminants in it after your recent diesel fill up.

    I would get Forte even if it is getting plugged tomorrow.

    Let me know how you get on. Some times the check engine light comes on if the dip stick has come up a little, It is a common fault on the 1.8 when boosting, the pressure pushes the dip stick out a tiny bit which creates a minor loss in the built up compression of the engine. We used to get this allot on Evo I's. I personally used to crimp the dip stick ever so slightly on customers cars and that used to sort it out.
    The other reason that the light might come on is due to the turbo starting to stick which causes the car to want to limp home. But that is mainly seen in the L200 diesel turbo which has a similar ECU programme to the 1.8 or so I was told by Yoshi Ren my Shudoshi in Japan but he was always drunk when he used to teach me so God only knows if he was telling the truth or pulling my leg:confused:

    I was only 17 at the time and used to take every thing as gospel!!!

    El
     
    #4
  5. 1.8GSturbo

    1.8GSturbo New Member

    Joined:
    Mar 3, 2010
    Messages:
    38
    Likes Received:
    0
    thanks mate, it does seem to be only after boosting it, the coil wires are really brittle gonna play with them as i noticed if i unplug the left coil for 1-4 it wont even fire a bit but i i leave the other on on it starts and cuts out coil pack could be failing...

    MOT- sit rep
    FAILED excessive corrosion NSR brake line (above tank)
    FAILED excessive corrosion OSR brake line (above tank)
    FAILED no hand brake wat so ever 0%
    FAILED co2 excessive (cat)
    ADVISORY OSR wheel bearing slight play
    ADVISORY rear barke discs corroded ( been parked up for 18months)


    could of been worse....

    the cat is specifically for my car and dealer only 650+vat!!!!!!!!!!!!!!
    can do the brakes myself..

    i might have to find a back street garage that will let me fit a d cat and nothing more said.....

    time to get the axel stands out and the tools again....
     
    #5

Share This Page

Advert: